読者です 読者をやめる 読者になる 読者になる

底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

LISP検証

cisco

仕事で使うかもしれないので簡易検証

構成

[RT-B]-------(10.0.1.0/30)-------[RT-A]-------(10.0.2.0/30)-------[RT-C]
   .2           .1   .1           .2


# 構成図のPPTを作るのを忘れたので、上で代用

上記の構成でのconfig

[RT-A]-------------------------------------------
interface FastEthernet0
ip address 10.0.1.1 255.255.255.252
!
interface FastEthernet1
ip address 10.0.2.1 255.255.255.252

----------------------------------------------------

[RT-B]-------------------------------------------
interface FastEthernet0
ip address 10.0.1.2 255.255.255.252
!
interface Loopback0
ip address 192.168.1.1 255.255.255.255
!
ip route 0.0.0.0 0.0.0.0 10.0.1.1

----------------------------------------------------

[RT-C]-------------------------------------------
interface FastEthernet0
ip address 10.0.2.2 255.255.255.252
!
interface Loopback0
ip address 192.168.2.1 255.255.255.255
!
ip route 0.0.0.0 0.0.0.0 10.0.2.1

----------------------------------------------------

この状態だと、RT-B、RT-C上で作成したloop0への経路がRT-Aのルーティングテーブルには存在しないため、RT-B〜RT-Cのloop0同士の通信は出来ない。

これを、LISPを使用して通信できるようにする。

 

LISP関連Config】

[RT-A]-------------------------------------------
vrf definition lisp
!
address-family ipv4
exit-address-family
!
router lisp
site sitea
description sitea
authentication-key sitea
eid-prefix 192.168.1.0/24
!
site siteb
description siteb
authentication-key siteb
eid-prefix 192.168.2.0/2
!
ipv4 map-server
ipv4 map-resolver
ipv4 alt-vrf lisp
!
----------------------------------------------------

[RT-B]-------------------------------------------
router lisp
database-mapping 192.168.1.0/24 10.0.1.2 priority 1 weight 100
ipv4 itr map-resolver 10.0.1.1
ipv4 itr
ipv4 etr map-server 10.0.1.1 key sitea
ipv4 etr
----------------------------------------------------

[RT-C]-------------------------------------------
router lisp
database-mapping 192.168.2.0/24 10.0.2.2 priority 1 weight 100
ipv4 itr map-resolver 10.0.2.1
ipv4 itr
ipv4 etr map-server 10.0.2.1 key siteb
ipv4 etr
----------------------------------------------------

 

【確認】
[RT-A]-------------------------------------------

#sho lisp site
LISP Site Registration Information

Site Name  Last   Up    Who Last   EID Prefix
      Register      Registered
sitea    00:00:51  yes    10.0.1.2    192.168.1.0/24
siteb    00:00:23  yes    10.0.2.2    192.168.2.0/24
----------------------------------------------------

RT-CからのPing

#ping 192.168.1.1 source 192.168.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.2.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

考え方的にはDNSにちょっと近いような印象。
ただ、LISPで使われる用語の意味や仕組みがまだ自分の中で消化できていないので要勉強