読者です 読者をやめる 読者になる 読者になる

底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

IPv6 multicast & BGP

cisco Linux

IPv6でのマルチキャスト

ただし、自身がIPv4でのマルチキャスト実務経験がないし、PIM-DMしか勉強してなかったので、このConfigはかなり怪しい。

 なので、再度見直しは必要だけど、とりあえず自身の頭の整理も兼ねて記載

f:id:klock_3rd:20160524002310p:plain

 

<R1>

router bgp 1
bgp router-id 1.1.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001::2 remote-as 2
!
address-family ipv6
neighbor 2001::2 activate
network 2001::/64
network 2001:0:0:4::/64
exit-address-family
!
address-family ipv6 multicast
neighbor 2001::2 activate
network 2001::/64
network 2001:0:0:4::/64
exit-address-family
!
ipv6 pim bsr candidate rp 2001:0:0:4::1

<R2>

router bgp 2
bgp router-id 2.2.2.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001::1 remote-as 1
neighbor 2001:0:0:1::2 remote-as 2
!
address-family ipv6
neighbor 2001::1 activate
neighbor 2001:0:0:1::2 activate
neighbor 2001:0:0:1::2 next-hop-self
network 2001::/64
network 2001:0:0:1::/64
exit-address-family
!
address-family ipv6 multicast
neighbor 2001::1 activate
neighbor 2001:0:0:1::2 activate
neighbor 2001:0:0:1::2 next-hop-self
network 2001::/64
network 2001:0:0:1::/64
exit-address-family
!
ipv6 pim bsr candidate bsr 2001:0:0:4::1

<R3>
interface Loopback0
no ip address
ipv6 address 2001:0:0:3::1/64
ipv6 mld join-group FF04::1 2001:0:0:4::1

 

この状態で、R1にて確認

R1#show ipv6 mroute

(2001:0:0:4::1, FF04::1), 00:04:55/00:02:41, flags: SFT
Incoming interface: Loopback0
RPF nbr: FE80::C80C:BFF:FE8C:0
Immediate Outgoing interface list:
Ethernet1/0, Forward, 00:01:15/00:03:16

とりあえず、R1~R3のshow ipv6 mrouteの結果は、multicastの(S,G)は表示される。

そこで、R1上でPingで確認

R1#ping ipv6 FF04::1
Output Interface: loopback0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FF04::1, timeout is 2 seconds:
Packet sent with a source address of 2001:0:0:4::1

Reply to request 0 received from 2001:0:0:3::1, 104 ms
Reply to request 1 received from 2001:0:0:3::1, 60 ms
Reply to request 2 received from 2001:0:0:3::1, 64 ms
Reply to request 3 received from 2001:0:0:3::1, 48 ms
Reply to request 4 received from 2001:0:0:3::1, 48 ms
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/64/104 ms
5 multicast replies and 0 errors.

 

ただし、R3のLoopback上の設定を・・・

 

<R3>
interface Loopback0
no ip address
ipv6 address 2001:0:0:3::1/64
ipv6 mld static-group FF04::1  FF04::1

上記のように「ipv6 mld static-group」の設定だとPingが応答しない。
これは、loopback0がJoinするのではなく、のIFの先に該当のマルチキャストグループが存在するという意味っぽい。