読者です 読者をやめる 読者になる 読者になる

底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

IPv6 over IPv4(手動)

cisco Linux

通信要件を整理していたら、やりたい事がどうもIPv4のネットワーク越しにIPv6通信を実現したい模様。

 

とりあえず手動でのトンネリングで検証

f:id:klock_3rd:20160619160918p:plain

 

<R1>

 interface FastEthernet0
ip address 10.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface Loopback0
no ip address
ipv6 address 2001:1::1/64
ipv6 enable
!
interface Tunnel0
no ip address
ipv6 address 2002:1::1/64
tunnel source 10.1.1.1
tunnel mode ipv6ip
tunnel destination 10.1.2.1
!
ip route 0.0.0.0 0.0.0.0 10.1.1.2
ipv6 route 2001::/64 Tunnel0

 

<R2>

 interface FastEthernet0
ip address 10.1.2.1 255.255.255.0
duplex auto
speed auto
!
interface Loopback0
no ip address
ipv6 address 2001::1/64
ipv6 enable
!
interface Tunnel0
no ip address
ipv6 address 2002::1/64
ipv6 enable
tunnel source 10.1.2.1
tunnel mode ipv6ip
tunnel destination 10.1.1.1
!
ip route 0.0.0.0 0.0.0.0 10.1.2.2
ipv6 route 2001:1::/64 Tunnel0

 

以下が確認結果

R2#ping 2001:1::1 source loop0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1::1, timeout is 2 seconds:
Packet sent with a source address of 2001::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms


とりあえず検証は終わり