読者です 読者をやめる 読者になる 読者になる

底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

再帰ルックアップの実用例?

Cisco本で再帰ルックアップのルーティングの本を見たことあったけど、いまいち使いどころが分からなかったので、「そういうのもあるのか」程度の認識だった。

 

ただ、こういう使い方だと便利だと納得したのがeBGPでの接続時

 

ISPとBGPで接続時、ISP側からBGPでのデフォルトルートを受け取れない場合
構成は↓

 

f:id:klock_3rd:20161005205124p:plain

R1がISP側BGPルータと仮定。 この場合R1がR2にデフォルトルートを通知しない場合、R2はすべての経路を受け取らないといけないのかと思ってたけど、再帰ルックアップで対処できそう。

 

まずは、適当につないでみる

<R1>

 interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
router bgp 1
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 192.168.1.254 remote-as 2
neighbor 192.168.1.254 soft-reconfiguration inbound
no auto-summary
!

 

<R2>

interface FastEthernet0/0
ip address 192.168.1.254 255.255.255.0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 1
neighbor 192.168.1.1 soft-reconfiguration inbound
no auto-summary
!

 この状態でのR2のshow ip route

 

#show ip route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
B 1.1.1.1 [20/0] via 192.168.1.1, 00:03:16
2.0.0.0/32 is subnetted, 1 subnets
B 2.2.2.2 [20/0] via 192.168.1.1, 00:03:16
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [20/0] via 192.168.1.1, 00:03:16
C 192.168.1.0/24 is directly connected, FastEthernet0/0

 

 とりあえず、R1のLo1~3までのアドレスが見える。 ただし、実際のISPだと大量の経路になると予想。 なので、Route-mapと再帰ルックアップを使用。

 

<R2>

router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 1
neighbor 192.168.1.1 soft-reconfiguration inbound
neighbor 192.168.1.1 route-map Lo1 in
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1
!
ip prefix-list Lo1 seq 5 permit 1.1.1.1/32
no cdp log mismatch duplex
!
route-map Lo1 permit 10
match ip address prefix-list Lo1

 この設定でのshow ip route

#show ip route

Gateway of last resort is 1.1.1.1 to network 0.0.0.0

1.0.0.0/32 is subnetted, 1 subnets
B 1.1.1.1 [20/0] via 192.168.1.1, 00:02:13
C 192.168.1.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 1.1.1.1

 

 この場合デフォルトルートをLo1のアドレスにして、lo1はeBGPで通知されることで再帰ルックアップでのデフォルトルートを実現。

試しにR1のlo1をshut後のR2を確認。

R2#show ip route

Gateway of last resort is not set

C 192.168.1.0/24 is directly connected, FastEthernet0/0

Lo1への到達性がなくなったのでデフォルトルートの設定もルーティングから消えている。

 

これまでは、eBGPでデフォルトルートをもらえなければ、どうしたものかと考えてたけどこれだとうまい感じでできそう。 事前に意識合わせは必要だけど。

 

 

確認おわり