底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

JUNOS_OSPF_DRとBDR

危うくハマりそうだったので、メモ

f:id:klock_3rd:20180517003458p:plain

OSPFのDR/BDRの確認
構成は↑

 

 R5をDR、R4をBDRとする。

R4

interface GigabitEthernet2
ip address 172.16.7.4 255.255.255.0
ip ospf priority 120
ip ospf 1 area 0
negotiation auto
end

 R5

set protocols ospf area 0.0.0.0 interface ge-0/0/0.0 priority 255

 

この状態でR3で確認

 R3#show ip ospf neighbor 
Neighbor ID  Pri State    Dead Time Address   Interface
1.1.1.4   120 FULL/BDR   00:00:39  172.16.7.4  GigabitEthernet2
2.1.1.5   255 FULL/DR   00:00:36  172.16.7.5  GigabitEthernet2
2.1.1.6    0 2WAY/DROTHER  00:00:37  172.16.7.6  GigabitEthernet2
2.1.1.7    0 2WAY/DROTHER  00:00:35  172.16.7.7  GigabitEthernet2
2.1.1.8    0 2WAY/DROTHER  00:00:33  172.16.7.8  GigabitEthernet2

 ここの表示は問題ない

上の状態で、R7はDROTHERと表示されているんで、じゃあR7で確認してみる。

admin@R7# run show ospf neighbor
Address    Interface     State  ID     Pri Dead
172.16.7.3   ge-0/0/0.0     2Way  1.1.1.3    1  32
172.16.7.4   ge-0/0/0.0     Full  1.1.1.4    120  35
172.16.7.5   ge-0/0/0.0     Full  2.1.1.5    255  38
172.16.7.6   ge-0/0/0.0     2Way  2.1.1.6    0  37
172.16.7.8   ge-0/0/0.0     2Way  2.1.1.8    0  33

 Ciscoで2way/DROTHERの箇所が2wayだけの表示。

自身がてっきりDROTHER表示されるもんだと思ってたので、exstart状態?と勘違いして、以下を確認。

 

 admin@R7# show protocols ospf | display set
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0 priority 0

 からの

 admin@R7# run show interfaces ge-0/0/0 brief
Physical interface: ge-0/0/0, Enabled, Physical link is Up
Link-level type: Ethernet, MTU: 1514, LAN-PHY mode, Speed: 1000mbps,

 OSPFはネイバー張る条件として「MTU長一致」もあったような気がするので、これが原因と危うく間違えそうになった。 まぁ、show route protocol ospfで?と気づいたんだけど。

 

DROTHER等の状態を確認するのは以下

admin@R7# run show ospf interface 
Interface    State Area    DR ID    BDR ID    Nbrs
ge-0/0/0.0    DRother 0.0.0.0   2.1.1.5   1.1.1.4    5

DRでは

 admin@R5# run show ospf interface
Interface    State Area    DR ID    BDR ID    Nbrs
ge-0/0/0.0    DR  0.0.0.0   2.1.1.5   1.1.1.4    5

 

ちなみに、R7のMTU「1514」を試しに1500に直してみる。

admin@R7# show interfaces ge-0/0/0 | display set
set interfaces ge-0/0/0 mtu 1500
set interfaces ge-0/0/0 unit 0 family inet address 172.16.7.7/24

R4で見ると

Neighbor ID  Pri State    Dead Time Address   Interface
1.1.1.3    1 FULL/DROTHER  00:00:36  172.16.7.3  GigabitEthernet2
2.1.1.5   255 FULL/DR   00:00:35  172.16.7.5  GigabitEthernet2
2.1.1.6    0 FULL/DROTHER  00:00:35  172.16.7.6  GigabitEthernet2
2.1.1.7    0 EXCHANGE/DROTHER00:00:37  172.16.7.7  GigabitEthernet2
2.1.1.8    0 FULL/DROTHER  00:00:36  172.16.7.8  GigabitEthernet2 

 

R5で見ると

 admin@R5# run show ospf neighbor     
Address    Interface     State  ID     Pri Dead
172.16.7.6   ge-0/0/0.0     Full  2.1.1.6    0  32
172.16.7.8   ge-0/0/0.0     Full  2.1.1.8    0  32
172.16.7.7   ge-0/0/0.0     Exchange 2.1.1.7    0  32
172.16.7.3   ge-0/0/0.0     Full  1.1.1.3    1  35
172.16.7.4   ge-0/0/0.0     Full  1.1.1.4    120  35

 

ついでにR7

 admin@R7# run show ospf neighbor
Address    Interface     State  ID     Pri Dead
172.16.7.5   ge-0/0/0.0     ExStart 2.1.1.5    255  34
172.16.7.4   ge-0/0/0.0     ExStart 1.1.1.4    120  31
172.16.7.3   ge-0/0/0.0     2Way  1.1.1.3    1  30
172.16.7.8   ge-0/0/0.0     2Way  2.1.1.8    0  33
172.16.7.6   ge-0/0/0.0     2Way  2.1.1.6    0  32