底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

JUNOS_VLAN(Native VLAN)

Ciscoのノリでやってしまったのでメモ

 

CiscoTagging&Native Vlan設定は以下

 

interface gi0/0
 switchport mode trunk
 switchport trunk allowed vlan 10-12
 switchport trunk native vlan 10

 こうすれば、vlan10がNative VLANとしてタグなし
このノリでJUNOSに入れる。

 

set vlans v10 vlan-id 10
set vlans v11 vlan-id 11
set vlans v12 vlan-id 12

set interfaces ge-0/0/2 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v10
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v11
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v12
set interfaces ge-0/0/2 unit 0 family ethernet-switching native-vlan-id 10

 確認すると・・・

 root# run show vlans detail

VLAN: v10, 802.1Q Tag: 10, Admin State: Enabled
Number of interfaces: 1 (Active = 0)
 Untagged interfaces: ge-0/0/2.0
 Tagged interfaces: ge-0/0/2.0

VLAN: v11, 802.1Q Tag: 11, Admin State: Enabled
Number of interfaces: 1 (Active = 0)
 Tagged interfaces: ge-0/0/2.0

VLAN: v12, 802.1Q Tag: 12, Admin State: Enabled
Number of interfaces: 1 (Active = 0)
 Tagged interfaces: ge-0/0/2.0

 ↑をみると、v10のTag/Untagともにge-0/0/2が表示

調べてみると、この場合の挙動は着信はUntagだけど送信はTagの模様。
正しくは以下

set interfaces ge-0/0/2 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v11
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v12
set interfaces ge-0/0/2 unit 0 family ethernet-switching native-vlan-id 10

 要は、memberからはv10は外す。

VLAN: v10, 802.1Q Tag: 10, Admin State: Enabled
Number of interfaces: 1 (Active = 0)
Untagged interfaces: ge-0/0/2.0 

 

 

ちなみに、VLAN-IFは、以下

set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v10
set interfaces irb unit 10 family inet address 1.1.1.1/32
set vlans v10 vlan-id 10
set vlans v10 l3-interface irb.10

特段難しいわけでもないけど、irb / vlan でアドレス振って、set vlanで割り当てる感じなので、Ciscoよりワンクッション必要なので忘れてしまいがち

 

後は、STP/RSTP/MST関連も検証したい。

これはCatalystがあればいいけど処分してしまったのが非常に悔やまれる。。。
DHCP snoopingとSPAN、dot1x関連位で見切りをつけるとしよう・・・