底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

cisco_vxlan

CiscoのVxLAN(L2 Gateway
まだ、理解していないので、後日調べるように貼り付け

 

SV1[172.1.1.1/24]----[gi4][R1][gi2]-----[gi2][R2][gi3]-----[gi2][R3][gi4]-----[172.1.1.2/24]SV2

 

 

R1


ip multicast-routing distributed
no ip domain lookup
ip domain name lab.com
!
bridge-domain 10
member vni 4096
member GigabitEthernet4 service-instance 10
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface nve1
no ip address
member vni 4096 mcast-group 239.10.10.1
source-interface Loopback0
!
interface GigabitEthernet2
ip address 10.1.1.50 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet3
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
!
router ospf 1
router-id 1.1.1.1
!
ip pim bidir-enable
ip pim rp-address 2.2.2.2 bidir
!

R2

 !
ip multicast-routing distributed
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.1.1.51 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet3
ip address 10.2.2.51 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
negotiation auto
!
router ospf 1
router-id 2.2.2.2
!
ip pim bidir-enable
ip pim rp-address 2.2.2.2 bidir
!

 

R3

 !
ip multicast-routing distributed
!
bridge-domain 10
member vni 4096
member GigabitEthernet4 service-instance 10
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface nve1
no ip address
member vni 4096 mcast-group 239.10.10.1
source-interface Loopback0
!
interface GigabitEthernet2
ip address 10.2.2.52 255.255.255.0
ip pim sparse-mode
ip ospf 1 area 0
negotiation auto
!
interface GigabitEthernet4
no ip address
negotiation auto
service instance 10 ethernet
encapsulation untagged
!
router ospf 1
router-id 3.3.3.3
!
ip pim bidir-enable
ip pim rp-address 2.2.2.2 bidir