底辺エンジニアの備忘録

30過ぎて、記憶力低下が著しい為、メモ代わりにしていく予定。 自身のスキルが低いので、内容の正確さは保障できません・・・OTL

JUNOS_RSTP(VSTP)

JUNOSのRSTP・・・厳密にはVSTPメモ
実際には、CiscoオンリーのNWはあったとしても、JuniperオンリーのNW構成は相当少ないだろうから、Ciscoも入れた下記構成で確認

f:id:klock_3rd:20180917014143p:plain

 まずは、3750のConfig

 !
spanning-tree mode rapid-pvst
!
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
!

 次はJUNOS側
SW1/SW2のconfig

set interfaces ge-0/0/2 unit 0 family ethernet-switching port-mode trunk
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v100
set interfaces ge-0/0/2 unit 0 family ethernet-switching vlan members v200

set interfaces ae0 unit 0 family ethernet-switching port-mode trunk
set interfaces ae0 unit 0 family ethernet-switching vlan members v100
set interfaces ae0 unit 0 family ethernet-switching vlan members v200

set protocols vstp vlan v100
set protocols vstp vlan v200

 

 この状態で、Cisco側のshowの結果(面倒なのでVLAN100のみ)

#show span vlan 100

VLAN0100
 Spanning tree enabled protocol rstp
 Root ID  Priority  32868
       Address   0026.cb1b.AAAA
       This bridge is the root
       Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  32868 (priority 32768 sys-id-ext 100)
       Address   0026.cb1b.AAAA
       Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
       Aging Time 300 sec

Interface      Role Sts Cost   Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1       Desg FWD 4     128.1  P2p
Gi1/0/2       Desg FWD 4     128.2  P2p

 

CiscoがRootブリッジになってるので、JUNOS側で確認

# run show spanning-tree interface

Spanning tree interface parameters for VLAN 100

Interface  Port ID  Designated   Designated     Port  State Role
             port ID    bridge ID     Cost
ae0.0      128:1    128:1 32868.7819f791BBBB   10000 BLK  ALT
ge-0/0/2.0   128:515    128:1 32868.0026cb1bAAAA   20000 FWD  ROOT

 

 Cost値に注目
ge-0/0/2のパスコストがCiscoの値(4)と異なっている のは、デフォルトでCiscoのパスコストが16bitで、JUNOSは32bitであるから。
試しにCisco側で32bitに変更してみる。

投入Config

(config)#spanning-tree pathcost method long

 投入後

#show spanning-tree vlan 100
(略)
 Interface      Role Sts Cost   Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1       Desg FWD 20000   128.1  P2p
Gi1/0/2       Desg FWD 20000   128.2  P2p

 →JUNOSのge-0/0/2のパスコストと同じ値になった。

 

 

今度は、Root bridgeをCiscoからJUNOS(SW1)に変更してみる。
SW1側で以下を投入

 # set protocols vstp vlan all bridge-priority 4k

これで、SW1がVLAN100、VLAN200Rootになると予想
commit&確認

# run show chassis mac-addresses
FPC 0 MAC address information:
Public base address 78:fe:3d:44:CC:CC
Public count 128

 

# run show spanning-tree bridge

STP bridge parameters
Context ID             : 1
Enabled protocol          : RSTP

STP bridge parameters for VLAN 100
 Root ID              : 32868.00:26:cb:1b:AA:AA
 Root cost             : 20000
 Root port             : ge-0/0/2.0
 Hello time            : 2 seconds
 Maximum age            : 20 seconds
 Forward delay           : 15 seconds
 Message age            : 1
 Number of topology changes    : 9
 Time since last topology change  : 1267 seconds
 Topology change initiator     : ge-0/0/2.0
 Local parameters
  Bridge ID            : 32868.78:fe:3d:44:CC:CC
  Extended system ID       : 1
  Internal instance ID      : 0

 

 想定と異なり、Root IDがCisco側にRoot Guardはないにも関わらずCiscoのまま。
設定投入の仕方を変える。

# delete protocols vstp vlan all
# set protocols vstp vlan v100 bridge-priority 4k

 SW1側で確認

# run show spanning-tree bridge

STP bridge parameters
Context ID             : 1
Enabled protocol          : RSTP

STP bridge parameters for VLAN 100
 Root ID              : 4196.78:fe:3d:44:CC:CC
 Hello time            : 2 seconds
 Maximum age            : 20 seconds
 Forward delay           : 15 seconds
 Message age            : 0
 Number of topology changes    : 10
 Time since last topology change  : 51 seconds
 Topology change initiator     : ae0.0
 Local parameters
  Bridge ID            : 4196.78:fe:3d:44:CC:CC
  Extended system ID       : 1
  Internal instance ID      : 0

 

 念のためCiscoでも確認

#show spanning-tree
 

VLAN0100
 Spanning tree enabled protocol rstp
 Root ID  Priority  4196
       Address   78fe.3d44.CCCC
       Cost    20000
       Port    1 (GigabitEthernet1/0/1)
       Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec

 Bridge ID Priority  32868 (priority 32768 sys-id-ext 100)
       Address   0026.cb1b.AAAA
       Hello Time  2 sec Max Age 20 sec Forward Delay 15 sec
       Aging Time 300 sec

Interface      Role Sts Cost   Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1       Root FWD 20000   128.1  P2p
Gi1/0/2       Altn BLK 20000   128.2  P2p

 

パスコストは忘れがちなので、Cisco--Juniperの混在環境では気を付けないと